Swan - Disruptions on card payments – Incident details

Disruptions on card payments

Resolved
Major outage
Started 12 days agoLasted 30 minutes

Affected

Cards

Major outage from 1:20 PM to 1:50 PM

Card payments

Major outage from 1:20 PM to 1:50 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Starting from 15:20 to 15:50 CET, we experienced a disruption in card payments, leading to card payments failing or delays in processing.