LIVE - Viewing the PIN code currently unavailable

Incident Report for Swan

Resolved

This incident has been resolved. The issue lasted from 18:14 CET until 20:48 CET.
Posted Feb 11, 2025 - 09:53 CET

Investigating

Starting from 18:14 CET, following user consent, the physical card PIN is not displayed as expected due to a technical error. We are currently investigating the issue and will provide updates accordingly
Posted Feb 10, 2025 - 18:53 CET
This incident affected: Card payment.