Limited access to Swan Support Center
Incident Report for Swan
Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 18:14 CEST
Investigating
Starting from 2:30pm CET, we have been experiencing issues on support center authentication resulting on the incapacity to login.
We are currently investigating on this issue.
Posted Jul 23, 2024 - 15:11 CEST
This incident affected: Swan website.