Swan - LIVE - Failure in Cards Management – Incident details
All systems operational
LIVE - Failure in Cards Management
Resolved
Partial outage
Started 6 days agoLasted less than a minute
Affected
Cards
Operational from 6:30 AM to 6:30 AM
Card management
Operational from 6:30 AM to 6:30 AM
Updates
Update
Update
This incident has been resolved.
Resolved
Resolved
From 23:07 CET on 7 Oct to 8:30 CET on 8 Oct 2025, PIN operations were impacted by a technical issue. Operations have since resumed. We are currently investigating the cause and will provide updates accordingly.