LIVE - Maintenance on card payments
Scheduled for September 24, 2025 at 11:30 PM – 11:45 PM
Affects
Cards
Under maintenance from 11:30 PM to 11:45 PM
Card payments
Under maintenance from 11:30 PM to 11:45 PM
Completed
September 24, 2025 at 11:45 PMCompleted
September 24, 2025 at 11:45 PMMaintenance has completed successfully
In progress
September 24, 2025 at 11:30 PMIn progress
September 24, 2025 at 11:30 PMMaintenance is now in progress
Planned
September 24, 2025 at 11:30 PMPlanned
September 24, 2025 at 11:30 PMOn September 25th, from 01:30 CET to 01:45 CET, we will be undergoing planned maintenance impacting card payments.
As a result, card payments will not be available during this period.