Card challenged transactions (3D Secure) service disruption.
Incident Report for Swan
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 18:04 CEST
Monitoring
Service seems operational since 12:55CEST. We are still waiting for Mastercard confirmation.
Posted Oct 15, 2021 - 12:55 CEST
Identified
A service disruption has been identified by Mastercard and customers may experience failures with challenged transactions (3D Secure). This issue is currently being handled by Mastercard and impact all issuers.
Posted Oct 15, 2021 - 11:34 CEST
This incident affected: Card payment.